Skip to Content

Here are a few things to help you get started on creating SAP Enterprise Widgets:

See  FINALLY !!! SAP Enterprise Widget Foundation Available for Download

Here are some videos to help you get started on the first video will show how to create a widget using a simple text editor.  The second video will show you how to integrate the SAP widget foundation into the widget.

 

Creating a widget from scratch 

Integrating the foundation into the widget

 

The user guide will guide you through the steps of setting up the foundation.  

SAP Enterprise Widget Foundation Users Guide

As always please let us know what you think.

To report this post you need to login first.

8 Comments

You must be Logged on to comment or reply to a post.

  1. Brian Carter
    Looks great, but after installing the Widget Foundation, stand alone version, tried to run the and received the following error:
    ‘Could not find the main class.  Program will exit.’.  Did review the troubleshoot but didn’t see how to resolve this.  Thanks
    (0) 
        1. Sunil Godwani
          Just uninstall SAP widget foundation.
          Now, uninstall all versions of JRE from your system including JRE6 and install only JRE 6. Make sure u dont have any version of JRE install apart from JRE 6.
          Now, install SAP Widget foundation again and install.
          (0) 
        2. Sunil Godwani
          Just uninstall SAP widget foundation.
          Now, uninstall all versions of JRE from your system including JRE6 and install only JRE 6. Make sure u dont have any version of JRE install apart from JRE 6.
          Now, install SAP Widget foundation again and install.
          (0) 
    1. Fredrik Pettersson
      Hi all, I also got the same error, so I studied the installation documents and actually found two parts containing different requirements.

      https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/20e64a36-6f34-2a10-0bbb-aeac6101b93c

      On page 3 it states that the following is required:
      • Windows XP
      • Java 1.6 or higher
      • SECUDE PSE Management
      SECUDE PSE Management must be installed if SECUDE SSO authentication is used.

      And on page 6 it is stated:
      The following software must be installed:
      • SAP Widget Foundation
      • Java Runtime Environment (JRE)
      • Yahoo! Widget Engine

      Confusing!

      (0) 
      1. Regina Sheynblat Post author
        On Page 3 of the documentation it states the requirements that are needed for the SAP Widget Foundation, on page 6 when you have already installed the foundation, this is what you need to run the widget itself.

        We will make it more clear in the next release of the documentation, also I will post shortly on the could not find the main class error message.

        Thanks for your feedback .

        Regina

        (0) 

Leave a Reply