Skip to Content

15 Comments

You must be Logged on to comment or reply to a post.

      1. kavitha krovi
        hi Venu,
        I am working with file to multiple Idocs scenario.It is on Production now.
        We are fine until july 7,2007. After that we faces some a problem that all the files are not sent to idoc. Ex: we sent 900 files and in that only 60 files are sent to r/3 and posting is stopped.Again we faced this problem on 10/july.
        In Moni, we donot have any detailed error. The trace is truncated.
        Will you please help on this issue. my mail id : kavitha_krovi@yahoo.com.
        thanks,
        regards,

        (0) 
        1. Venugopalarao Immadisetty Post author
          Hi,

            Copy all the files in your test systetm check all the files are picking from the source system and all the messages are coming to in XI moni.
          Here you need to fix your problem why all the files are not picking from the source..there could a problem with sender file communcation channel.

            Monitor the file adapter in Adapter framework.

          If all the files are picking from the source check in moni with same date all the message are coming to moni or not.

          Regards,
          Venu.

          (0) 
  1. Reddy P
    Hi Venu,

    Can you provide more details on point 4? In SXMB_ADM, where exaclty I can enter the values Category: RUNTIME, Parameter: LOGGING, Current Value: 1 ?

    Thanks,
    Reddy P

    (0) 
    1. Venugopalarao Immadisetty Post author
      Hi Redddy P,

      Can you provide more details on point 4?
        -> When you click on message in SXMB_MONI, by default pipeline steps do not appear. If you want to see all the pipeline steps, you need to do the setting in SXMB_ADM .(Please check the below explanation of SXMB_ADM)
        -> Pipeline steps are (Source message ->RD->ID->MS->MM>TR->CA-> Target message)
        RD -> Receiver Determination
        ID -> Interface Determination
        MS -> Message split
        MM -> Message mapping
        TR -> Technical routing
        CA -> Call adapter

      Using the XI pipeline steps we can find out the source payload and the payload after the mapping conversion. It also explains as to what happens in each pipeline step during runtime.


      In SXMB_ADM, where exaclty I can enter the values Category: RUNTIME, Parameter: LOGGING, Current Value: 1 ?

        -> Tcode SXMB_ADM
        -> Execute Integration engine and configuration
        -> Click on Specific configuration
        -> Go to change mode and add new entry (Category: RUNTIME, Parameter: LOGGING, Current Value: 1) then Save.

      Regards,
      Venu.

      (0) 
    1. Venugopalarao Immadisetty Post author
      Hi,

        Go to XI, Tcode : SXMB_MONI Double click on any message and right hand side it will appear the pipeline steps. To appear pipeline steps in SXMB_MONI need to do external setting in Tcode :SXMB_ADM – (Read the Point No:4 in the blog).After done the settings trigger the scenario then new message will come in SXMB_MONI and double cick that message in SXMB_MONI you can see the pipeline steps.

        By default pipeline steps it won’t appear in SXMB_MONI without external setting in SXMB_ADM.

      Regards,
      Venu.

      (0) 
  2. sudha rani
    THANKS A LOT .
    THIS BLOG IS VERY MUCH USEFUL FOR ME.
    RIGHT NOW IAM LEARNING XI, WILL U PLS HELP ME MR.VENUGOPAL HOW WRITE XI-CERTIFICATION EXAM?

    (0) 
  3. Madhulatha Lingareddy
    i have checked your posting on this particualr error,but before you comment on my query i would like to elaborate more on my query.

    ours is idoc to http scenario.
    idoc is being triggered and the data is being posted on http url.but an ack is also being generated by http service(which is not actually neede by us).Now this ack is giving an error as Unable to convert the sender service to an ALE logical system.

    NOTE: LS is maintained for idoc in we20 and we21 in r/3 system.also we have mentioned the LS name in business service in configuration too.but LS is not maitained for Http service in configuration.Also the http vendors are being maintained under LI in we20 in r/3 system.

    Is there anything taht we missed or is the procedure we followed is incorrect?kindly suggest.

    regards
    Madhu

    (0) 
    1. Venugopalarao Immadisetty Post author
      Hi Madhu,

         To disable the ackw error you need to add the table entry in XI : IDXNOALE

      Sender Port : Which is created in XI
      Sender Client : The above Port what client &
      Message type : What is the Message type Used.

      then you test the your scenario…..Still if you are getting the ack error then you need to execute the report : IDX_NOALE and test your flow.

      Regards,
      Venu.

      (0) 
  4. deepak jaiswal
    Hi Venu,
           where we have to configure logical system for Business service/Business system for file to idoc communication i.e on PI system or in R3 system?

    It will be helpful if we have a demo steps of doing all this activities.

    Thanks
    Deepak

    (0) 
    1. Ajay Mukundan
      Hi Deepak,

      You need to configure Logical system in both PI as well as R/3 system. You need to create Business sytem in PI from ID (Integration Directory).

      Thanks,
      Ajay

      (0) 

Leave a Reply