Skip to Content
Sometimes the link between XI and target system (say ERP) goes down. Generally, messages are picked up and sent via XI when the link returns. However, in some scenarios, it may be possible that XI server could not finish conversation with ERP. Main status of messages is “Processed successfully” – but there is an error in the outbound side as shown below. (Transactions – SXI_MONITOR/SXMB_MONI).  image   These messages do not get picked up automatically – and it is not possible restart them from using RWB or the transactions like SXI_MONITOR/SXMB_MONI.   Such messages could be processed in the following way:    ** Send data directly to Integration Engine **   ** Change the status of failed message **       This example shows how to solve the problem – two error messages are shown and one of them is solved here.    Step 1: Send data directly to Integration Engine    Go to +Component Monitoring +in XI Runtime Workbench. Click on the +Test Message+ tab for the Adapter Engine. Specify the URL of XI Integration engine to send the message to e.g. http://Send the message using +Send Message+ button.     Step 2: Change the status of failed message   Call the transaction SWWL.  image  Delete appropriate work items.  image  Check that the messages are complete in SXI_MONITOR/SXMB_MONI.  image
To report this post you need to login first.

6 Comments

You must be Logged on to comment or reply to a post.

  1. Varalakshmi SB
    Hi Riyaz ,

    We have Workflow item error in our Production and i performed the steps as in blog.

    -My only concern is in RWB:When we send the payload , we have USER/Password to be entered.Is that the PI Service login credentials(Eg:PIAFUSER) to be entered.KIndky suggest .

    Thanks,
    Vara

    (0) 

Leave a Reply