Skip to Content
According to the branding policy of your company some times you must adapt the logon page, in this blog i’ll give you some tricks about how to make “basic” adaptations in order to change the images and the Portal title

image

This trick is also valid if you don’t want to make full changes as described at: SAP Help Portal but want to “customize” your logon page.

First of all, change the images:

image

The images on the logon screen are hosted in the web server area for your WebAS 6.40, you can change it in two ways:
Option 1:

– Connect to to server where the Portal WebAS is running and go to:
(drive):\usr\sap\SID\JCNN\j2ee\cluster\server0\apps\sap.com\com.sap.security.core.admin\servlet_jsp\logon\root\layout

There you will find the images used on logon screen, you can replace them for your company images, please take care with the width of the images, as usual, to make this change effective, you must restart the whole WebAS.

Note: each time you upgrade the WebAS (install a new SPS) these images willbe overwritten, so take it into account in order to replace it again after upgrade.

Option 2:

– Connect to the Portal’s WebAS Visual Administrator
– Go to “Global Configuration” -> Server -> Services -> UME Provider
– look for following properties: ume.logon.branding_image and ume.logon.branding_text
– Change the image location for the desired one, but be sure the new images are present on a web server location over the WebAS

Now let’s change the browser title:

– Connect into your Portal with user that have super_admin role
– Follow this path: System Administration -> System Configuration -> Service Configuration -> Portal Runtime
– On the Portal Runtime folder you will find the Central Configuration object , please double click on it, then look into the Property Editor for property “portal.html.head.title” and change the value to the desired one
– Then SAVE the changes by pressing the Save button in the Property Editor page (bottom)

To make this change effective you also must restart the entire WebAS.

I hope you find this useful

To report this post you need to login first.

11 Comments

You must be Logged on to comment or reply to a post.

  1. Anonymous
    Hi Luis,

    just to be complete: the browser title is also overwritten with every SPS. So, you’ll have to change this parameter again after each SPS installed.

    Greetz,
    Alex

    (0) 
  2. Ricky Ford
    Hi Felipe,

    i changed the image in the folder specified and restarted but still the image in the logon screen remains the same.

    Regards,
    Ricky

    (0) 
        1. Vicky Liesens
          Hi Sunitha,
          I have the same problem that you have, can you please inform me if you have found the issue and how you resolved it?
          Thanks
          Vicky Liesens
          (0) 
  3. Yonghua Wang
    Luis,

    With the SP12 deployed. The Portal didn’t allow the changes make in virtual admin tool (option two in your blog). When I save it, it pops up and says you need to restart the J2EE and I click yes, but the changes I made were rolled back. I have the similar experiences when I change the default framework page. After J2EE restarts, it rolled back all my changes. It is a bug in SP12?

    (0) 
  4. Community User
    Great blog. I used a combination of option 1 and 2. The first option to place the new image and the second to change ‘UME.logon.branding_image’ to the new image name without overwriting the SAP standard.

    I also found I had to place the image in the directory /usr/sap/SID/JCNN/j2ee/cluster/server0/apps/sap.com/irj/servlet_jsp/irj/root/portalapps/com.sap.portal.runtime.logon/layout as well.

    (0) 
  5. Kumar T
    Hi ,
      After modifying the images in the Layout , and deploying the par with default name (com.sap.portal.runtime.logon.par)

    Do i need to update the authscheme.xml and also do i need to restart my server.

    if so , may i know the reason in detail…

    Kindly clarify

    –>Ramesh

    (0) 
  6. Kumar T
    Hi ,
      After modifying the images in the Layout , and deploying the par with default name (com.sap.portal.runtime.logon.par)

    Do i need to update the authscheme.xml and also do i need to restart my server.

    if so , may i know the reason in detail…

    Kindly clarify

    –>Ramesh

    (0) 
  7. Matt Fraser

    I’ve been trying to make this work in our Sandbox Portal, without success.  Admittedly, the instructions here are for 6.40 and we are using 7.01 (Netweaver 7.0 EhP1).  Still, the paths and such seem to apply.  I’ve placed our logo image file in both \usr\sap\Matt

    (0) 

Leave a Reply