Skip to Content

I spent about one week to install Sneak Preview SAP NetWeaver 04 on my PC. I encountered a timezone problem during installation and login failure problem after installation. Finally, I found a perfect procedure to avoid all possible problems.

System Environment

  1. Windows Server 2003 Enterprise Edition SP1
  2. Physical Memory 1 GB
  3. Free Space in C: 50 GB
  4. This machine is just a part of workgroup.  style=”color: #FF0000″>It is not a member of domain.

Installation Steps

  1. Make sure that you have installed main memory at least 512 MB. Otherwise, increase virtual memory to 1 GB
  2. Apply all critical patches at http://windowsupdate.microsoft.com/
  3. Install WinRAR (if you don’t have it yet). The latest trial version as of Today is available at http://www.rarlab.com/rar/wrar35b7.exe
  4. Download J2SE SDK 1.4.2_08 and install it now if you don’t have it. By default, it will be installed at c:j2sdk1.4.2_08
    image
  5. Download the Sneak Preview
  6.  

  7. Extract the archives using WinRAR by right clicking on file NW04SneakPrevJavaSP11.part1.rar and choose Extract here. At this point , you should see a new directory NW04SneakPrevJavaSP11
    image
  8. Change regional setting in Control Panel -> Regional and Language Options as follows:
    image 
    • Regional Options  
         

      • Standards and formats: German (Germany)
      •  

      • Location: Germany
      •  

        image

    •  

    • Advanced  
         

      • Language for non-Unicode programs: German (Germany)
      •  

        image

  9. Accept to reboot
    image
  10. Change timezone in Control Panel -> Date and Time to GMT+01:00 at Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna with Automatically adjust clock for daylight saving changes turned on
    image
    image
  11. Run SAPinst.bat in directory NW04SneakPrevJavaSP11NWSneakPreviewSP11
    image
    image
  12. Log off if necessary
    image
  13. Accept the license agreement
    image
  14. Specify J2SDK path
    image
  15. Leave database parameters as default but adjust I/O Buffer Cache to 128 MB
    image
  16. Enter Log size by 1500 MB or more
    image
  17. Enter Database volume by 1500 MB or more
    image
  18. Verify summary and start the execution
    image
  19. Congratulations! The software should be successfully installed on your machine. Do not test it immediately. Please follow the next step.
    image
  20. Start SAP Management Console on the desktop
  21. At this point, you might see 3 instances here: a database and two SAP (instance number 0 and 1)
    image
  22. You might see the instance 0 is currently offline (grey). If yes, you need to start it now. The color will turn to yellow. It might take a while. Please wait until it is completely started (green).
    image
    image
  23. Add en-us to Internet Explorer
    image
  24. Now you are ready to test NW’04 by opening http://localhost:50000/irj
    image
  25. Try to login with user admin and password admin
    image

For timezone problem, you might try to change your timezone to any timezone with dayling saving enabled.

To report this post you need to login first.

29 Comments

You must be Logged on to comment or reply to a post.

  1. Anonymous
    HI Sugree

    Very useful weblog.I really want to try out this but i am not able to download the sneak preview from sdn. So if you can sent the sneak preview to my mail id, it would be of great help to me .
    My mail id is urajeev2000@yahoo.com

    Rajeev.

    (0) 
      1. Raktim Banerjee
        Hi All
        I was facing the problem in installintion of sneak preview. I am using Windows XP Srrvice Pack 2. First thing I did is that I disabled windows firewall from control panel. Then also I was facing problem like localhost port 21212 is not connected. Then I opened this port in the McAfee Desktop Firewall. Then I faced series of problem related to firewall. I opened these ports : 7210, 3601, 3201 and 50020 . So please open those port or else disable any desktop firewall before installation.
        Regards
        raktim
        (0) 
      1. Sugree Phatanapherom Post author
        The export data has some parts containing daylight saving information. This information will not be imported correctly on timezone without daylight saving.
        (0) 
        1. Siddhesh Ghag
          I had not seen this weblog and went ahead without the timezone change.

          I got an error in the Load Java Database content phase the error description being Error in some date format or something like that..

          After changing the timezone and setting it to CET it worked…

          This blog is useful… thanks

          (0) 
    1. Sugree Phatanapherom Post author
      I don’t sure about language. Actually, at the second installation, I changed timezone and the installation process passes through without problem. Unfortunately, I can’t login with any users including SAP*. I tried to activate SAP* account in UME with no luck.

      At the third installation, I changed both language and timezone and everything worked fine. I repeated the steps again and it worked again. This weblog was my forth installation.

      (0) 
  2. P. Hurton
    A good post, and I too struggled with this install.  But IMHO, it ABSOLUTELY riciculous that one must go through such pain to try out this product.  Other software vendors provide much simpler solutions.  I think SAP could do much better!
    (0) 
    1. P. Hurton
      Just to be clear, I’m talking about the painful install process of sneak preview. WE do find the SAP EP quite powerful/useful.  I don’t intend to indict the product only the painful install process
      (0) 
      1. Sugree Phatanapherom Post author
        I see your point. Unfortunately, nothing’s perfect. That’s why SAP has provides OSS note. And again, this is just a sneak preview made by limited developers. We are now beta testers. Next version will hopefully be better if we find and report bugs to the developers.
        (0) 
  3. Iyengar Karthik
    I did this on a Windows XP system SP2. Added complexity f getting out of a domain, then changing the time-zone & getting back ino the domain to beat the password length logic. The time-zone change part & the painful way of dropping MaxDB either through DOS or the crude way of deleint registry entries & then the SAPDB folder made me waste a lot of time on this.

    One of the most paiful installs I have been through. Thanks for your blog on the time-zone being set to GMT+1 – would you know why? The java.txt and java.load.txt were of more help than the log viewer.

    Kartik Iyengar~

    (0) 
    1. Sugree Phatanapherom Post author
      Good point! I forgot to indicate that my machine has not been a member of any domain at all. Shortly, the installation failure usually doesn’t depend on OS but its setting (timezone/domain/policy).
      (0) 
    2. chess mennow
      HI Karthik,
      Netweaver Java Edition Preview install is hanging at phase 18 (Load Java Database Content). java.txt and java.load.txt don’t have any errors or exception. I found that the last entry in java.txt is 13.11.05 04:17 com.sap.inst.jload.Jload dbImport INFO: table J2EE_CONFIGENTRY created and the last entry in java.load.txt is 13.11.2005 04:17:21 com.sap.inst.jload.Jload dbImport INFO: EP_LOCK_APPLS loaded (1 rows).

      Can u let me know what information can we obtain from java.txt and java.load.txt and how long does it take for phase 18 (Load Java Database Content) to finish.

      Thnx

      (0) 
      1. Sasi Kiran Upadrasta

        Hi, <br/><br/>Please set the following Environment Variables:<br/>JAVA_HOME: <JDK-INSTALL-PATH><br/>JAVA_SAPINST_JRE: <JDK-INSTALL-PATH>\jre<br/>Also add<br/><JDK-INSTALL-PATH>\bin to the ‘Path’ Environment Variable.<br/><br/>With 768MB RAM, the installation took just around an hour on my machine.

        (0) 
  4. Adam Reeves
    I presume that one can revert this to their original values after the install.

    I would also like to add that when extracting the second rar archive it seems to have duplicate files to the first archive, this concerned me at first and I performed the extract in different directories to check. A bit time consuming, so just to let you know  that this seems to be normal, so just answer yes to overwrite all files.

    Another bit of information, as this web log suggests once installed, you have to startup up one of the sap instances in the SAP management MMC. You do say this may take a while, mine took about 1 hour and the log files were detailing connection timeouts, again this appears normal, just wait for it to startup.

    Good web log though, save me a lot of time, I had orginally tried installing the Linux version of this trial got very close but failed, I will probably return back to Linux once the issues have been ironed out with that version.

    (0) 
  5. Stefan Blumer
    All stated is true.  I’ve installed now on two different PC and had several pains.  The domain is a real pain and one best removes the PC from it to go around password policies.  I also run into an issue with my second install where I run out of disk space.  One would assume that after freeing up some additional room on the hard drive the PBNW install process can be restarted.  That was not true in my case, I got an error message that the dB connection could not be established.  So I tried to uninstall a partial installed PBNW…  Removing the dB was a major issue, I had to go true the registry and delete all SAP related entries manually (a 3 hour job!).  After that the install worked fine.

    Thanks for providing all this info.
    Stefan

    (0) 
    1. nathaniel briggs
      Sugree and/or Anyone else:

      I’ve had nothing but problems installing this product: NetWeaver 04 Sneak Preview Slim SP11

      Every time I install, it simply loops back to “Restarting/Logging Out” (See Log Below)

      I’ve followed the instructions *(above & else in this blog/site), and triple checked everything.

      Platform: Windows XP Pro
      User: Administrator

      SAP Install Log:

      WARNING 2005-09-01 00:40:40 [ianxbusprv.cpp:271]
      CIaNtUserPrivileges::add_impl(., EBOLA\Administrator, SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege)

      Could not determine whether the current user has the right SeTcbPrivilege.
      INFO 2005-09-01 00:40:40 [ianxbusprv.cpp:327]
      CIaNtUserPrivileges::add_impl(., EBOLA\Administrator, SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege)

      Successfully added privileges ‘SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege’ to account ‘EBOLA\Administrator’ on host ‘.’.
      WARNING 2005-09-01 00:40:40
      CJSlibModule::writeWarning_impl()
      SAPinst needs to log you off………
      __________________________________________________

      LOG OUT & LOG IN
      __________________________________________________

      INFO 2005-09-01 00:44:44
      CJSlibModule::writeInfo_impl()
      File not found: [C:/DOCUME~1/ADMINI~1/LOCALS~1/Temp/sapinst_exe.2776.1125560364/msvcp71.dll].
      INFO 2005-09-01 00:44:44
      CJSlibModule::writeInfo_impl()
      File not found: [C:/DOCUME~1/ADMINI~1/LOCALS~1/Temp/sapinst_exe.2776.1125560364/msvcr71.dll].
      WARNING 2005-09-01 00:44:45 [ianxbusprv.cpp:271]
      CIaNtUserPrivileges::add_impl(., EBOLA\Administrator, SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege)

      Could not determine whether the current user has the right SeTcbPrivilege.
      INFO 2005-09-01 00:44:45 [ianxbusprv.cpp:327]
      CIaNtUserPrivileges::add_impl(., EBOLA\Administrator, SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege)

      Successfully added privileges ‘SeTcbPrivilege SeAssignPrimaryTokenPrivilege SeIncreaseQuotaPrivilege’ to account ‘EBOLA\Administrator’ on host ‘.’.
      WARNING 2005-09-01 00:44:45
      CJSlibModule::writeWarning_impl()
      SAPinst needs to
      log you off ……..
      ___________________________________________________

      LOG OUT & LOG IN
      __________________________________________________

      INFO 2005-09-01 01:02:11 [synxcsymgt.cpp:133]
      CSySystemMgtImpl::reLogin()
      Switching user: new user (unknown)

      FAIL

      Any feedback/help? ‘Cause I’ve seriously had it…

      NB @ syntheticmagic@yahoo.com

      (0) 
  6. Thomas Br├╝ckner
    Hi, I’ve already spent some hours trying to install the NW 04 Sneak Preview. It seems to work fine, but the trouble is, I cannot login. I’ve tried admin/admin, but always get the message that the login failed. Same thing with the administration tools. Did anybody face the same problem?

    Thanks,
    Thomas

    (0) 
    1. Haresh Khandal
      Hi,

      I do face the same problem. After giving username as admin and password as admin. It gives error message.

      If you’ve solved it out, please let me know what to do for it.

      I have tried to create new user, which is successfull.

      Thanks,

      -Haresh

      (0) 
  7. Yohan Attal
    Hello,

    I’m facing a problem while installing SAP NetWeaver 2004S under my system (Windows XP SP2 1Go Ram). I got the administrator rights and exit my antivirus. I got this message log in the berginning of the installation:

    […]
    Execute step setNWOption of component |NW_Java_OneHost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_getJavaHome|ind|ind|ind|ind|0|0.
    INFO 2007-02-06 14:06:39
    Execute step collect of component |NW_Java_OneHost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_GetSidNoProfiles|ind|ind|ind|ind|1|0.
    WARNING 2007-02-06 14:06:40
    Error 5 (Accès refusé.
    ) in execution of a ‘RegOpenKeyEx’ function, line (69), with parameter (SYSTEM\CurrentControlSet\Services\Disk).
    WARNING 2007-02-06 14:06:40
    The subkey ‘HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk’ does not exist on the ‘localhost’ host.
    ERROR 2007-02-06 14:06:40
    MOS-01185  The subkey ‘HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Disk’ does not exist on the ‘localhost’ host.
    ERROR 2007-02-06 14:06:40
    FCO-00011  The step collect with step key |NW_Java_OneHost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_GetSidNoProfiles|ind|ind|ind|ind|1|0|collect was executed with status ERROR .

    Looks like it can’t find the registry linked to the disk. Would someone be helpful and explain to me what’s wrong ?

    Thanks you!

    (0) 
    1. Peta Gergen
      Hi

      Had a similar problem with NW2004s on my mchine with the following error:
      ERROR 2007-05-30 10:21:25
      MOS-01185  The subkey ‘HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BlackICE’ does not exist on the ‘localhost’ host.

      The Solution was to delete and recreate the registry entry from another similarly configured machine. After more discussion among colleagues there may be another explanation in that the registry hive permissions did not allow sapinst to read the affected key and thus it returned an error.

      Best Regards
      Peta M Gergen
      pgergen@kpmg.com.au

      (0) 

Leave a Reply